Glow – Important Changes to Browser Compatibility for O365

This week Microsoft provided an update on some changes being implemented across Office 365 (workloads are their term of the various tools within O365 such as SharePoint and Lync for example).

microsoft ie requirements

The above screenshot is taken from this link.

You will see from the above that older versions of O365 are likely to give you a diminished experience of some elements of O365 – older versions listed above are IE8 and IE9 and the same will apply for anyone on earlier versions of IE.

There is an area of Glow set up that provides further information on the technical requirements of each of the services, this will be of most relevance to those involved in the management of school firewalls and networks and it allows the testing of each of the components, because of this it sits behind the Glow authentication and is available here.

Posted in Help and Support, News, O365
2 comments on “Glow – Important Changes to Browser Compatibility for O365
  1. I would like some help with signing into glow,please?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: